Service Degradation

Incident Report for PaymentWorks

Resolved

This incident has been resolved. Teams have rolled back the released code to resolve the issue driving latency in certain application areas.
Posted Aug 21, 2024 - 12:11 EDT

Update

We are continuing to monitor for any further issues.
Posted Aug 21, 2024 - 12:02 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 21, 2024 - 12:02 EDT

Investigating

Currently, our Web Application Platform is experiencing service degradation. We will continue to monitor and update this status.
Posted Aug 21, 2024 - 11:59 EDT
This incident affected: Web App.