Vendor Number/ Site Code Display Issue

Incident Report for PaymentWorks

Resolved

This incident has been resolved.
Posted Sep 02, 2026 - 13:11 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 02, 2026 - 11:16 EDT

Identified

Our team has identified the source of this display issue and we are currently working on a fix.
Posted Sep 02, 2026 - 10:22 EDT

Update

We are continuing to investigate this issue.
Posted Sep 02, 2026 - 10:18 EDT

Investigating

Our team is aware of an issue currently impacting the display of vendor numbers and site codes within the Profile Manager interface. We have confirmed that this issue is limited to the display of this information and that the underlying data is being saved correctly.

We are actively working to resolve the issue and will provide additional updates as progress is made.
Posted Sep 02, 2026 - 10:08 EDT
This incident affected: Web App.