Email Notification Delay on Pending Payment Reviews

Incident Report for PaymentWorks

Resolved

PaymentWorks Team has resolved the incident. Pending Payment Notification emails are being sent as expected from the system. If you have any questions or need any emails to be resent, please reach out to PaymentWorks Support HERE
Posted May 22, 2024 - 15:50 EDT

Monitoring

A fix has been identified and monitoring is in place. Teams have confirmed that emails are being sent out to any Customer with pending payments as expected.
Posted May 22, 2024 - 15:41 EDT

Identified

PaymentWorks has identified certain system emails that were not sent as expected. The scope of emails impacted relates only to Customers with payment files in review. The teams are actively working on a resolution and will be providing an update every 30 minutes until resolved.

In the interim, please utilize the PaymentWorks platform to view payment files and complete approvals per your standard process.
Posted May 22, 2024 - 15:29 EDT
This incident affected: Payments Uploads and Processing.