Intermittent homepage outage

Incident Report for PaymentWorks

Resolved

PaymentWorks homepage is fully functional.
Posted Jul 06, 2024 - 20:21 EDT

Update

We are continuing to investigate this issue.
Posted Jul 06, 2024 - 20:20 EDT

Investigating

PaymentWorks is actively triaging an intermittent outage on our homepage. If you are experiencing issues, please utilize https://www.paymentworks.com/df/accounts/login/ to login to your account.
Posted Jul 06, 2024 - 19:52 EDT
This incident affected: Homepage.