We’ve confirmed that all queued email notifications from Friday, July 11, through today have now been successfully sent.
We’re closing out this incident, but if you believe you’re still missing an email notification—or if you have any questions—please don’t hesitate to reach out to our Support team.
We sincerely appreciate your patience and collaboration throughout this process. Special thanks to those who reported delays—your input helped us investigate quickly and drive a fast resolution.
Thank you, PaymentWorks Support
Posted Jul 15, 2025 - 21:09 EDT
Monitoring
Good afternoon,
We’ve identified the issue causing delays in some automated email notifications sent from no-reply@paymentworks.com and have taken action to address it.
All system nodes have been refreshed, and we’re now seeing email delivery working as expected. Delayed emails are being processed from oldest to newest, so you may receive a message related to an action that’s already been completed—no problem! These are still being delivered for audit and recordkeeping purposes.
This delay did not impact any onboarding or approval workflows—all actions have continued to process normally within the PaymentWorks platform.
We’ll continue monitoring closely, but no action is needed from customers at this time. If you have any questions, you can check the PaymentWorks interface for the latest status updates.
Thank you for your patience and partnership, PaymentWorks Support
Posted Jul 15, 2025 - 18:08 EDT
Identified
Good afternoon,
We’re currently working on a fix for a delay affecting some automated email notifications sent from no-reply@paymentworks.com.
Please note: This issue does not impact onboarding or approval workflows. All actions are processing as expected within the PaymentWorks platform.
We are already seeing improvements in email timing, and want to reassure you that all emails will be sent, even if they arrive later than expected. These notifications will still be available for your audit or documentation purposes once received.
Our teams are actively implementing a solution and continuing to monitor email delivery performance and related services to ensure full resolution.
Updates will be posted here as we learn more.
No action is needed at this time. If you have questions about onboarding or approval status, you can continue to view updates directly within the PaymentWorks interface while we work to restore normal delivery timing.
Thank you for your patience and partnership, PaymentWorks Support
Posted Jul 15, 2025 - 17:00 EDT
Investigating
Good afternoon,
We’re currently investigating a delay affecting some automated platform email notifications.
Please note: this issue does not impact onboarding or approval workflows. All actions are processing as expected within the PaymentWorks platform.
Our teams are actively reviewing the email queueing and delivery system to identify the root cause. We’re closely monitoring all related services and delivery metrics.
Updates will be posted here as we learn more.
No action is needed at this time. If you have questions about onboarding completion or registration approval status, you can continue to view updates directly within the PaymentWorks interface while we work to resolve the delay.
Thank you for your patience and partnership, PaymentWorks Support
Posted Jul 15, 2025 - 16:42 EDT
This incident affected: Vendor Onboarding and Approvals.