Intermittent connection issues with PaymentWorks homepage.

Incident Report for PaymentWorks

Resolved

This incident has been resolved.
Posted Jun 22, 2024 - 19:40 EDT

Update

We are continuing to investigate this issue.
Posted Jun 22, 2024 - 19:36 EDT

Investigating

We are currently investigating an issue with the PaymentWorks homepage.
Posted Jun 22, 2024 - 19:32 EDT
This incident affected: Homepage.