PaymentWorks Home Page
Incident Report for PaymentWorks
Resolved
Good evening,
This issue has been fully resolved, and no further action is needed at this time.

Thank you for your patience.

Kind regards,
PaymentWorks Support
Posted Nov 26, 2024 - 21:29 EST
Monitoring
Update:
The PaymentWorks home page (www.paymentworks.com) is now taking traffic. Our team is actively monitoring traffic and system logs to ensure continued stability and performance.

We appreciate your patience during this time and will provide further updates again once we can confidently closeout.

Thanks all!
PaymentWorks Support
Posted Nov 26, 2024 - 20:50 EST
Investigating
Good Evening,

We are currently experiencing an issue with the PaymentWorks home page (www.paymentworks.com), preventing access. Our team is investigating the issue, and we will provide updates as they become available.

Workaround:
You can access your account directly using this link: https://www.paymentworks.com/df/accounts/login/.

Thank you for your patience as we work to resolve this issue.

Kind regards,
PaymentWorks Support
Posted Nov 26, 2024 - 20:41 EST
This incident affected: Homepage.