Issue Impacting NVR Exports and Onboarding Tracker

Incident Report for PaymentWorks

Resolved

This incident has been resolved. Full access to all parts of the platform has been restored.
Posted Jan 05, 2026 - 17:07 EST

Monitoring

A fix has been implemented and we are monitoring the progress.
Posted Jan 05, 2026 - 17:04 EST

Investigating

PaymentWorks is currently investigating an issue impacting NVR exports and access to the onboarding tracker. Our team will provide updates as we work to resolve the issue.
Posted Jan 05, 2026 - 16:05 EST
This incident affected: Web App.