Payments File Processing Delays

Incident Report for PaymentWorks

Resolved

A permanent fix has been put into place, Payments processing fully operational and healthy. We'll continue to monitor logs.
Posted Dec 11, 2023 - 13:13 EST

Monitoring

Payments processing is back to normal timelines. We'll continue to monitor and report on any updates.
Posted Dec 11, 2023 - 12:50 EST

Investigating

We're currently investigating reports of delayed payments file processing. We'll continue to report status changes as we discover the cause.
Posted Dec 11, 2023 - 12:13 EST
This incident affected: Payments Uploads and Processing.