The issue preventing payees from submitting registrations has been resolved. Our engineering team quickly identified the root cause and implemented a rollback of recent code changes to restore functionality.
Registrations are now working as expected. We will continue to monitor the system closely to ensure stability.
Thank you for your patience as we worked to address this issue promptly.
Posted Dec 10, 2024 - 15:30 EST
Identified
Good afternoon, We are currently investigating an issue where payees are unable to submit their registrations. Our team is working to identify the root cause and implement a resolution as quickly as possible.
We apologize for the inconvenience and will provide updates as we learn more.
Thank you for your patience and understanding.
Kind regards, PaymentWorks Support
Posted Dec 10, 2024 - 15:29 EST
This incident affected: Vendor Onboarding and Approvals.