Intermittent Latency in Uploads, Validations, and Notifications (Resolved)

Incident Report for PaymentWorks

Resolved

Incident Summary:
Earlier today, we observed increased latency across several services, including:

- Uploading supplier files
- Sending email notifications
- TIN and bank account validations
- PIF parsing and bank delivery
- Payment evaluations

These delays were temporary and may have impacted processing times by up to approximately 30 minutes.

Our team identified the root cause and implemented a fix. The issue has been resolved, and system performance has returned to normal.

Current Status:
Resolved – All affected systems are operating normally. No further impact is expected.

Next Steps:
No action is required from users. If you continue to experience issues, please don't hesitate to contact our Support team.

Kind regards,
PaymentWorks Support
Posted May 30, 2025 - 12:49 EDT