Monitoring shows sanctions processing with our 3rd party provider is now within our preferred turnaround of 24 to 48 hrs. Pending Sanctions Reviews incident is considered resolved. Please reach out to PaymentWorks Customer Support if you are experiencing unexpected results. Thank you for your patience and partnership.
Posted Dec 26, 2023 - 09:40 EST
Update
PaymentWorks team continues to monitor sanctions processing with our 3rd party provider. We apologize for any delays that may be impacting end-of-year onboarding. Thank you for your continued patience while we work to resolve this delay and maintain secure Vendor data.
Posted Dec 18, 2023 - 10:39 EST
Monitoring
PaymentWorks is monitoring progress to ensure all data will be processed successfully.
Posted Dec 14, 2023 - 14:45 EST
Investigating
Due to higher volumes at the end of the year, our industry-leading third-party partner is experiencing longer than normal processing times for sanctions checks. This delay impacts PaymentWorks and our Customers. We are closely monitoring sanctions processing and do not currently have specific timeframes for when pending sanctions will be completed.
Posted Dec 14, 2023 - 14:38 EST
This incident affected: Vendor Onboarding and Approvals.