PaymentWorks systems are fully operational. Our platform is stable, and all services have recovered successfully following the AWS resolution. We’ll continue to monitor performance closely but no additional impact is expected at this time.
Posted Oct 20, 2025 - 19:08 EDT
Identified
Since 1:00PM EDT, we are observing intermittent issues in utilizing SFTP. At this time we recommend uploading files via the UI. Our team is continuing to work to bring our systems fully operational.
Posted Oct 20, 2025 - 15:43 EDT
Monitoring
Earlier this morning, PaymentWorks was alerted to Amazon Web Services (AWS) experiencing a widespread outage that affected multiple major platforms globally. Our systems are mostly stable, but we are actively monitoring AWS's recovery efforts — they have reported "significant signs of recovery," and we expect full resolution over the coming hours.
Next Update: We will continue to monitor and post again once all systems are fully operational.