Blank Page Issue

Incident Report for PaymentWorks

Resolved

This issue has been resolved.
Posted Mar 31, 2026 - 16:32 EDT

Identified

Our team has identified a fix and will be releasing it shortly
Posted Mar 31, 2026 - 16:20 EDT

Investigating

PaymentWorks is actively triaging an issue where some users are seeing a blank page after sign-in or when navigating between pages. Our Engineering team is actively investigating and working to restore full functionality. Thank you for your patience as we actively work to get this resolved.
Posted Mar 31, 2026 - 16:01 EDT
This incident affected: Web App.