Incident: Intermittent Blank Page for Some Users

Incident Report for PaymentWorks

Resolved

The blank page issue has been fully resolved. Users should now be able to sign in and navigate the PaymentWorks platform normally.

Thank you for your patience while we worked to restore service.
Posted Oct 21, 2025 - 16:15 EDT

Monitoring

A fix has been deployed for the blank page issue. Early results indicate that users should now be able to sign in and navigate without issue. We are closely monitoring system performance to confirm full resolution.

Users should now be able to sign in and navigate the PaymentWorks platform normally.

Thank you for your patience while we worked to restore service.
Posted Oct 21, 2025 - 16:12 EDT

Investigating

PaymentWorks is actively triaging an issue where some users are seeing a blank page after sign-in or when navigating between pages. Our Engineering team is actively investigating and working to restore full functionality. Thank you for your patience as we actively work to get this resolved.
Posted Oct 21, 2025 - 16:06 EDT
This incident affected: Web App.